System Requirements – Starter Templates

Here are system requirements to run Starter Templates plugin smoothly –

  • WordPress version 5.0 or above
  • PHP 7 or above
  • MySQL 5.6 or above/ MariaDB version 10.0 or above
  • WP Memory limit of 128 MB or greater

Note: If you are not sure if above versions are running on your server, we recommend you to contact your hosting provider.

Along with above system requirements here are few more that you would need to work with the plugin –

Servers
If your website is hosted by WP Engine, you might need to add SSL to your website to avoid saving issues.
If you use SiteGround or GoDaddy, make sure that they modify the SubstituteMaxLineLength of your server for you.

X-Frame Options
It has to be set to “same origin” to avoid editing issues. Please ask your host to do this for you.

PHP Z-Lib Extension
It is preferable to have PHP Zlib extension enabled on your server. Please ask your host to enable this for you, if it is not.

Device
You will need desktop computers or laptops to edit templates. It is not possible to edit them with mobile phones and tablets.

Browsers
Use Chrome, Firefox, Safari, or Microsoft Edge version 79 or greater.

Not the solution you are looking for? Check other articles, or open a support ticket.